Posted  by  admin

Apt Get Install Certain Version

In a typical install of Ubuntu, Apt will automatically try to install the highest version it can locate in any repository that it knows about. Manually browsing to the international, US and IL repositories did confirm your requested version is not available for download.

  • Using apt-get command to install specific version of package in Ubuntu Linux. Ubuntu users can install package from previous release or install a specific version of a package. A specific version of a package can be selected for installation by following the package name with an equals and the version of the package to select.
  • By doing an apt-cache show subversion-tools I was able to see the two available packages. These are the steps I went through to install the backported version of subversion-tools, although these steps will work when installing any specific version of a Debian package. Before you install a specific version of a package you need it's complete.
  • The highest possible version is 4.10.0-27. To install it just type the following apt-get command/apt command: $ sudo apt install linux-image-4.10.0-27-generic OR $ sudo apt-get install linux-image-4.10.0-27-generic Sample outputs.
  • I'm trying to install Openssl onto a new Ubuntu Server 11.10 box and I was wondering if there was a way to use apt-get and install an older version. When I use 'apt-get install openssl' it installs the newest version.

Installing packages with the apt-get package manager on Ubuntu or Debian usually fetches the latest known version from the repositories. This is a comfortable behavior to use an up-to-date version of the package.

If you want to install a specific package version, you can do that by appending an equal sign and the version number to the package name:

Apt-get Install Certain Version

For example, the command to install Elasticsearch in version 6.2.4 looks like this:

Apt get install version

That’s it! Awesome, huh 😃

Apt Install Specific Version

If you run into issues it may relate to outdated repositories. Ubuntu and Debian may not ship or reference the latest package releases.

Installing packages with the apt-get package manager on Ubuntu or Debian usually fetches the latest known version from the repositories. This is a comfortable behavior to use an up-to-date version of the package.

If you want to install a specific package version, you can do that by appending an equal sign and the version number to the package name:

For example, the command to install Elasticsearch in version 6.2.4 looks like this:

That’s it! Awesome, huh 😃

GetApt-get

If you run into issues it may relate to outdated repositories. Ubuntu and Debian may not ship or reference the latest package releases.